Requirements

  • AngularFaces 2.1 requires Java 6 or above. As for the client side it supports Javascript and AngularJS.
  • AngularFaces 2.1 requires JSF 2.2 or above. It supports both Oracle Mojarra and Apache MyFaces.
  • PrimeFaces 5.0 and above are supported (and probably earlier versions, too). That doesn't mean PrimeFaces is required: PrimeFaces is an optional (but highly welcome) library.
  • AngularFaces 2.1 is compatible to OmniFaces 1.7 and 2.0.
  • BootsFaces 0.6.5 or above is supported.

AngularFaces uses AngularJS 1.3.9 and jQuery 1.11.1. In production mode (i. e. web.xml context parameter javax.faces.PROJECT_STAGE set to Production ), the minified versions are loaded. Otherwise, the debugger-friendly version is used.

Alternatively you can provide your own version of AngularJS and jQuery. AngularFaces checks the resources bearing the head target. If AngularFaces detects a resource called angular*.js , angular-messages*.js , jquery-ui*.js or jquery*.js , it doesn't add the built-in version of the corresponding library.

Dart and AngularDart

A future version of AngularFaces will support Dart and AngularDart, but I've postponed Dart support because I'm waiting for a couple of announced breaking changes in AngularDart.